Splash Screen Not Displaying on Android After Upgrading to SDK 40

Please provide the following:

  1. SDK Version: 40.0.0
  2. Platforms(Android/iOS/web/all): Android


I recently upgraded from SDK Version 38 to 40. My app used to have a splash screen that displayed correctly using the AppLoading component, but since the upgrade, my splash screen does not appear in the Expo Client and appears as the Expo logo in standalone builds.

I’ve already modified the import statement according to the release notes, as you can see in my code below.


// ...
import AppLoading from 'expo-app-loading';
// ...

export default function App() {

  const [fontsLoaded] = useFonts({
    // ...

  if (!fontsLoaded) {
    return <AppLoading />
  } else {
    return (
      <Navigator />


  "expo": {
    "splash": {
      "image": "./assets/splash.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"

How should I proceed to get my splash screen back?

1 Like

Hey @ahbarkun, can you provide a reproducible example of this that we can run on our end? I’m not having any issues with displaying a splash screen on a project running SDK40.


1 Like

I am running into this same issue, were you able to find a fix?

I’ve been swamped and haven’t had time to make a reproducible error for @adamjnav. I haven’t found a solution yet, though the correct splash screen does appear in the Expo client now (haven’t tried with standalone builds).

I’ll try to get that reproducible error up by the end of the week, but if it’s pressing for you you may want to post one for @adamjnav to take a look :slight_smile:

My issue turned out to be my CI pipeline was using an older version of expo-cli, after updating the splash screen worked again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.