Splash image not visible during app load

The splash image during app load does not appear instead it shows a blank white screen. Previously I was at least able to set the default splash screen while currently no image seems to be applied. I’ve tried creating another apps wherein the splash image is perfectly working.

Expo Diagnostics :
Expo CLI 3.26.2 environment info:
OS: macOS 10.15.6
Shell: 3.2.57 - /bin/sh
Node: 12.18.3 - /usr/local/bin/node
Yarn: 1.22.10 - /usr/local/bin/yarn
npm: 7.0.15 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
Android Studio: 4.0 AI-193.6911.18.40.6626763
Xcode: /undefined - /usr/bin/xcodebuild
expo: ~40.0.0 => 40.0.0
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
expo-cli: 3.26.2


{ "expo": { "splash": { "image": "./assets/app-splash.png", "resizeMode": "contain", "backgroundColor": "#ffffff" },

I’m about to end the first sprint of the application, during the initial stages the splash screen was visible but in time it disappeared after some changes in the app.json file. I had a thought that I may create a new expo project and apply changes for this issue which I may not be wanting. I would like to get some suggestions over the issue resolution. If there be any other info needed please let me know.


Hey @wevak, what platform(s) is this occurring on?

I’ve used Pixel XL API 30 & Pixel 3a API 30 emulators on iMac system.

Issue solved upon updating the expo-cli.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.