Something went wrong Packager is not running at ...

I don’t know how the problem resolved, the thing i did last night was

  • I did closed metro builder using ‘CTRL+C’ Command
  • I did try to clear npm cache using npm clean cache
  • run npm verify cache

when nothing worked I did shutdown my laptop.

The magical thing that happened in the early morning when I woke up and tried to run the project was that ’ The project was running fine’ .

But there is a problem when I kill my experience and restart metro builder i.e
The screen you see below have two port on which the project is running Port 80 and Port 19000

Thank you so much @wodin for the help!

1 Like

And when I click on either ,the same problem arose i.e
Something went wrong Packager is not running at port 80

This seems to happen because Metro bundler has exited. So the error is correct. The packager is not running on port 80 (or any other port). So the solution would involve figuring out why the packager dies.

@wodin You are absolutely correct. Whenever accidentally I close the expo client or my terminal and when I restart the terminal and rerun the command expo start , It takes port 80 and try to open the project at port 80 meanwhile the project is running on port 19000.

This problem can be resolved by killing the experiece at both end the production device and the client device(i.e Android or ios) on which user is running the project.

Thank you @wodin!!! It wouldn’t be possible without your help.


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.