[SOLVED] Problem with react native navigation tab or drawer in stand alone


I have been develop expo for less than 2 months and recently i face some weird issue

I have react native tab and drawer using react navigation.

It work well since version expo 20 and 21 until last week where it stop working when i deploy into stand alone app (ios only) on my tab and drawer.

Below would be a sniplet of my code

tabBarComponent: props => {
const p = this.props;
return (

active={props.navigationState.index === 0}
onPress={() => {
props.navigation.navigate(“Home”, {kenny_reload: “ok”});


it work well in expo app (ios and android) and android without any issue at all.

anybody face the same issue?

Have you tried running your project after publishing it with XDE/exp and opening the published project in the Expo client? When you publish – as well as when you run in a standalone app – the JS is built with development mode off and minification enabled, which sometimes can cause different behavior in your JS.

1 Like

I did published and try using expo client. It work well but not in stand
alone (iOS) only

I have tried with build for simulator and it seem to have the same problem.

@ide i still stuck with this problem for iOS only. I try to go for stand alone build but i’m stuck with “exponent.app” path…

i have try to build with development mode off and mini enable but there are no error at all.

my project is in my profile. If you try with expo client and it work perfectly

I have download the simulator mode but i’m not sure where to set the debugging mode on for it.

after weeks (very long week) of dismantle the apps, i found the way to make it work. I just move navigation instead of putting everything into 1 file and split them into multiple file.


No idea why it work on dev and android stand alone but it fail to work in ios stand alone. I’m just happy that its close and hope it help others