[Solved] Fatal error : '../Basics/Internal/FBSDKBasicUtility+Internal.h' file not found

Trying to migrate a detached expokit app in sdk33. I followed the process described here.
pod install worked fine, but when I run react-native run ios, after a bunch of compilation lines, it stops with the following error :

CompileC /xxx/ios/build/sharesapp/Build/Intermediates.noindex/Pods.build/Debug-iphonesimulator/EXFacebook.build/Objects-normal/x86_64/EXFacebook.o /xxx/node_modules/expo-facebook/ios/EXFacebook/EXFacebook.m normal x86_64 objective-c com.apple.compilers.llvm.clang.1_0.compiler (in target: EXFacebook)
    cd /xxx/ios/Pods
    export LANG=en_US.US-ASCII
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -x objective-c -arch x86_64 -fmessage-length=0 -fdiagnostics-show-note-include-stack -fmacro-backtrace-limit=0 -std=gnu11 -fobjc-arc -fmodules -fmodules-cache-path=/xxx/ios/build/sharesapp/ModuleCache.noindex -fmodules-prune-interval=86400 -fmodules-prune-after=345600 -fbuild-session-file=/xxx/ios/build/sharesapp/ModuleCache.noindex/Session.modulevalidation /..../ -o /xxx/ios/build/sharesapp/Build/Intermediates.noindex/Pods.build/Debug-iphonesimulator/EXFacebook.build/Objects-normal/x86_64/EXFacebook.o
In file included from /xxx/node_modules/expo-facebook/ios/EXFacebook/EXFacebook.m:9:
/xxx/ios/Pods/Headers/Private/../Private/FBSDKCoreKit/FBSDKInternalUtility.h:22:9: fatal error: '../Basics/Internal/FBSDKBasicUtility+Internal.h' file not found
#import "../Basics/Internal/FBSDKBasicUtility+Internal.h"
1 error generated.

WriteAuxiliaryFile /xxx/ios/build/sharesapp/Build/Intermediates.noindex/Pods.build/Debug-iphonesimulator/EXFacebook.build/Objects-normal/x86_64/EXFacebook.LinkFileList (in target: EXFacebook)
    cd /xxx/ios/Pods
    write-file /xxx/ios/build/sharesapp/Build/Intermediates.noindex/Pods.build/Debug-iphonesimulator/EXFacebook.build/Objects-normal/x86_64/EXFacebook.LinkFileList

error Failed to build iOS project. We ran "xcodebuild" command but it exited with error code 65. To debug build logs further, consider building your app with Xcode.app, by opening sharesapp.xcworkspace

Building with XCode, I can see that the path is incorrect, there is no “/Internal”.
#import "../Basics/FBSDKBasicUtility+Internal.h

Hey @lc3t35, thanks for doing some digging on this:

Building with XCode, I can see that the path is incorrect, there is no “/Internal”.
#import "../Basics/FBSDKBasicUtility+Internal.h

Were you able to build successfully after fixing the file path?

No it does not work, there are many incorrect paths …

Still the same after update to sdk44 :frowning:

Having the same issue here.

[Solved] I’ve updated with latest expo as shown above by expo diagnostics :

  Expo CLI 3.0.9 environment info:
      OS: macOS 10.14.6
      Shell: 5.3 - /bin/zsh
      Node: 10.16.0 - /usr/local/bin/node
      Yarn: 1.17.3 - /usr/local/bin/yarn
      npm: 6.9.0 - /usr/local/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
      Android Studio: 3.4 AI-183.6156.11.34.5692245
      Xcode: 10.3/10G8 - /usr/bin/xcodebuild
      expo: 34.0.4 => 34.0.4
      react: 16.8.3 => 16.8.3
      react-native: https://github.com/expo/react-native/archive/sdk-34.0.1.tar.gz => 0.59.8
      react-navigation: 3.11.1 => 3.11.1
      expo-cli: 3.0.9

and ios/2.12.4 in Podfile (due to this issue 'EXBranch/EXBranchManager.h' file not found on blank ejected ExpoKit project · Issue #5231 · expo/expo · GitHub)

pod 'ExpoKit',
    :git => "http://github.com/expo/expo.git",
    :tag => "ios/2.12.4",
    :subspecs => [
    :inhibit_warnings => true
1 Like

Thanks for sharing this fix, @lc3t35!

1 Like