[SOLVED] ExpoKit SDK 32 pod install fail

I run pod install on a fresh expokit project and I got this error

[!] CocoaPods could not find compatible versions for pod "GoogleSignIn":
  In Podfile:
    EXGoogleSignIn (from `../node_modules/expo-google-sign-in/ios`) was resolved to 2.0.0, which depends on
      GoogleSignIn (~> 4.4)

    ExpoKit/Core (from `http://github.com/expo/expo.git`, tag `ios/2.10.2`) was resolved to 32.0.0, which depends on
      GoogleSignIn (~> 4.1)

Specs satisfying the `GoogleSignIn (~> 4.4), GoogleSignIn (~> 4.1)` dependency were found, but they required a higher minimum deployment target.

What should I do in this case?

Anyone has any ideas?

Hey @bankify_expo_admin,

I just ejected a fresh project and ran pod install. I didn’t encounter this error but did get an error for the FBAudienceNetwork pod. Running pod install --repo-update fixed it however.

Cocoapods version 1.5.3
expo-cli version 2.6.14

Can you try ejecting again and see if you still encounter the aforementioned error?




Thanks! running that command helps!

Awesome! Glad I could be of help. Thanks for bringing this issue to light as well.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.