(Solved) Expo asking for credentials suddenly

We’ve been using expo for building ipa’s for awhile from the command line, but suddenly it asks for:

Trying to authenticate with Apple Developer Portal…
Authenticated with Apple Developer Portal successfully!
Only 1 team associated with your account, using Apple Team with ID: xxxxx
We are missing the following credentials from you: Apple Distribution Certificate, Apple Push Notifications service key, Apple Provisioning Profile
? How would you like to upload your credentials?
❯ Expo handles all credentials, you can still provide overrides
I will provide all the credentials and files needed, Expo does limited validation

I believe last time we did this we let expo “handle all credentials”, but now it’s asking again and if expo is handling them - we don’t have a lot of them.

I’m worried about calling that again, as I’m not sure what the consequences are.

When I select “I will provide all creds”, I can’t seem to find all the files needed on the Apple Developer web page.

  1. Are there any consequences to running Expo handles all credentials, you can still provide overrides multiple times?
  2. For giving them certs, which are on the apple page and which do we need to have saved (i.e. like private keys)

Please run expo diagnostics and paste the log that’s printed out along with your question or issue!

Expo CLI 3.9.1 environment info:
OS: Linux 4.15 Ubuntu 18.04.3 LTS (Bionic Beaver)
Shell: 4.4.20 - /bin/bash
Node: 10.16.3 - ~/.nvm/versions/node/v10.16.3/bin/node
npm: 6.11.1 - ~/.nvm/versions/node/v10.16.3/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
@types/react: ^16.9.11 => 16.9.11
@types/react-native: ^0.60.22 => 0.60.22
expo: ^34.0.3 => 34.0.4
react: 16.8.3 => 16.8.3
react-native: https://github.com/expo/react-native/archive/sdk-34.0.0.tar.gz => 0.59.8
react-navigation: ^3.11.1 => 3.11.1
expo-cli: 3.9.1

Fixed it, it was because we have seperate App.json files for different envs, and the one we had in there was not the prod one - which means the identifier was incorrect, and expo has never managed those credentials. :slight_smile:

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.