Solved: App Rejected by Apple: "Namespace SPRINGBOARD"

Hello guys,

It has been a real pleasure working with Expo so far, and I was finally happy to send my app to the App Store.

However, you’ve seen the title, I got rejected! :pensive:

Here’s what they said:

Your app crashed on iPad running iOS 12.1 connected to an IPv6 network when we:

Loaded the application.

We have attached detailed crash logs to help troubleshoot this issue.

{"app_name":"ExpoKitApp","timestamp":"2018-11-24 16:19:55.49 -0800","app_version":"1.0.0","slice_uuid":"bd35c6d5-60de-3b5a-b061-713cb76029c0","adam_id":1443636465,"build_version":"1.0.1","bundleID":"com.eveningkid.storescreens","share_with_app_devs":false,"is_first_party":false,"bug_type":"109","os_version":"iPhone OS 12.1 (16B92)","incident_id":"754CC34A-386A-4555-83DC-98B2014EEEEB","name":"ExpoKitApp"}
Incident Identifier: 754CC34A-386A-4555-83DC-98B2014EEEEB
CrashReporter Key:   23c67f275a52e293a2d116bc638cd6154c6e73b0
Hardware Model:      xxx
Process:             ExpoKitApp [8369]
Path:                /private/var/containers/Bundle/Application/98CA1F9D-87C5-4C28-B682-639B26DB3C67/
Identifier:          com.eveningkid.storescreens
Version:             1.0.1 (1.0.0)
AppStoreTools:       10B63
Code Type:           ARM-64 (Native)
Role:                Non UI
Parent Process:      launchd [1]
Coalition:           com.eveningkid.storescreens [2943]

Date/Time:           2018-11-24 16:19:55.1062 -0800
Launch Time:         2018-11-24 16:19:34.9569 -0800
OS Version:          iPhone OS 12.1 (16B92)
Baseband Version:    7.21.00
Report Version:      104

Exception Type:  EXC_CRASH (SIGKILL)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note:  EXC_CORPSE_NOTIFY
Termination Reason: Namespace SPRINGBOARD, Code 0x8badf00d
Termination Description: SPRINGBOARD, scene-create watchdog transgression: com.eveningkid.storescreens exhausted real (wall clock) time allowance of 19.10 seconds | ProcessVisibility: Foreground | ProcessState: Running | WatchdogEvent: scene-create | WatchdogVisibility: Foreground | WatchdogCPUStatistics: ( | "Elapsed total CPU time (seconds): 18.020 (user 18.020, system 0.000), 30% CPU", | "Elapsed application CPU time (seconds): 0.421, 1% CPU" | )
Triggered by Thread:  0

And here is the full crash logs:

It seems to be about an “Namespace SPRINGBOARD” error?
The app would get stuck on the splash screen.

The weird thing is that I just updated my iPad to iOS 12., tried it using TestFlight and it works.

Would you have any leads on what may be the problem? Or advice?
Please, let me know if you need any extra information.

Again, I couldn’t thank you more for making Expo a reality. It is a great help for all of us, thank you.

1 Like

No clue? This really prevents me from publishing the app…

Hi @eveningkid,

The IPv6 message is often a red herring that indicates their test environment but might not be related to the failure. or iOS standalone - rejected at review because of IPv6 might be helpful in tracking it down.

Good luck!

@thetc thank you for your answer.

I previously checked the same links and couldn’t find anything in common.
My app isn’t making any network request…

I tried it on TestFlight, even without wifi turned on after installing, and it runs great.
I made a couple more builds to make sure I wasn’t missing something (maybe I do), and it still works fine with/without internet when using the same build I sent to them but with TestFlight.

Is there a difference between what they run and the version I’m trying with TestFlight? Or is there any other way I could try to “debug” the app?

Thank you.

Alright, I got accepted. If anyone runs into the same issue: make another build, send it again. I don’t know for what reason but it worked after submitting the app again (without any other change…).

Thanks for your help @thetc, seems like magic got into it. :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.