Social logins (Google, FB) refer to my app as "ios" when trying to sign in

This isn’t an error, per se. But it is something that was working as I intended before I started using EAS. I’ve changed nothing about my app.json for the app’s name to change from what it should say to now being:

“ios” wants to use Google to sign in.
“ios” wants to use Facebook to sign in.

Fortunately, because everything is still hooked up correctly as far as client keys, the correct app icon and image shows up in the UI when the user is selecting their account. It’s just a minor annoyance.

I am wondering if eas.json requires me to set my app name there since I am building my app with the eas build command?

My setup:

  • managed workflow
  • eas-cli/0.37.0 darwin-x64 node-v14.16.1

Hey @michaellaw9, can you share what SDK version you are using as well as what modules to implement your social login flows?

Also, did this issue occur immediately after you built with EAS or has it worked properly before with eas build?

Cheers,
Adam

1 Like

I just figured I can use

    "ios": {
      "infoPlist": {
        "CFBundleName": "My App"
      },
      ...

To change what reads in the alert, with the above yielding in:

“My App” Wants to Use “google.com” to Sign In

1 Like

Hey @admjnav, I’m using Expo SDK 42. The issue did seem to appear immediately after building with EAS and it did in fact work properly before when I was using the standard expo build:ios. The libraries I’m using are below.

"expo-facebook": "~11.3.1",
"expo-google-app-auth": "~8.2.5",

@timoisalive I’m assuming that goes in app.json? Or does that go in eas.json?

what is your app name in app.json?

It’s “Rewards App”, and it says that when I build using EAS for the simulator, but when running standalone in production, it refers to the app as “ios”.

can you share your app.json and package.json? and run expo diagnostics and eas diagnostics in your project?

We have a similar issue. All worked as expected until we decided to change the app name(before release). But Facebook and Google auth still ask: oldappname wants to use Facebook/Google to sign in. The only place where it still exists its package name for android and bundleIdentifier for ios(which we can change only by resubmitting the app to stores): com.companyName.oldappname

Is it correct behavior?

That sounds wrong. But are you sure the old name is not defined in the server side? (i.e. Google/Facebook).

Also, can you please provide the info that notbrent asked for above?

Came back to verify that this was the solution.

I’m not 100% certain that merely building with EAS is what caused the issue, but adding CFBundleName to ios.infoPlist in app.json did cause the name to be displayed correctly.

Hey there, was waiting on an Apple app review to verify my answer. The solution by timoisalive is the correct answer.

Also, I’m 100% sure the old name was not defined on the server in either the Google/FB sdks

1 Like

Good to hear! I’ve actually not yet submitted a build even to TestFlight with this new config, I’ve only been building a dev client for simulator so far. So good if it works in a “real” build as well! :+1:

1 Like

I know this has been solved but I thought I’d share this from Apple’s developer site:

CFBundleName is a user-visible short name for the bundle. The system may display it to users if CFBundleDisplayName isn’t set.

CFBundleDisplayName is the user-visible name for the bundle, used by Siri and visible on the iOS Home screen.

CFBundleSpokenName is a replacement for the app name in text-to-speech operations.

CFBundleName,CFBundleDisplayName,CFBundleSpokenName

Mike

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.