Slider images show in local dev but not published or standalone

Hey gang,

I’m writing an expo app with a custom slider. It looks great when I’m previewing it in the expo preview app, but when I build it for standalone, it just renders the default slider (ie, with no images.)

All other images / media are working.

Anyone know where to start debugging this?

Hi @jpteasdale. Does the published url work in the main Expo app? If not, I’d recommend turning off dev mode and enabling minify in exp or XDE. This will be closer to how the published app behaves and you could debug there.

Hey @jesse you were right, the published .js bundle didn’t work in Expo. I’m just starting it with yarn start, I’m looking at the documentation and I don’t see how to turn off development mode / minify from there.

I ran it with exp start --no-dev --minify and it still works locally. When I exp publish, it still doesn’t show.

Edit: I made the app public if anyone wants to take a look.

Here’s a snack that demonstrated the behavior.

I ended up making my own slider component. I imagine the problem was because of some sort of loading behavior that was different in the published app. Very strange.

Here’s the slider code if anyone’s interested.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.