Simulator not installed but... it is?

I keep getting this error:
Simulator not installed. Please visit to download Xcode and the iOS simulator. If you already have the latest version of Xcode installed, you may have to run the command sudo xcode-select -s /Applications/

I tried running the command and nothing worked. Uninstalled node-modules and re-installed and nothing. I noticed that in my ~/.expo folder I don’t have a folder named ios-simulator-app-cache and when I looked for solutions online people mention deleting the contents of this folder. I can open a simulator just fine running this command open -a Simulator but when I run this command xcrun simctl install booted ~/.expo/ios-simulator-app-cache/ nothing happens because there is nothing there. This is extremely frustrating. It was working just fine yesterday but now it can’t open xcode simulator because a file just magically disappeared?

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.