Signing certificate is not valid for code signing

When running expo build:ios I constantly run into the error on the build pipeline.
Signing certificate “XXXX”, serial number “XXX”, is not valid for code signing. It may have been revoked or expired.
However I have run expo build:ios -c a number of times, cleared out all the credentials with no luck.
I’ve tried both creating them all myself, as well as letting expo handle the creation of all the certificates.

I’ve tried the latest expo-cli 3.17.X, the latest 3.18.X and 3.19.0

Expo CLI 3.19.0 environment info:
      OS: macOS 10.15.3
      Shell: 3.1.0 - /usr/local/bin/fish
      Node: 12.14.0 - /var/folders/9g/3kj7knmj46d0bwh4rsj44fd00000gn/T/yarn--1587528255776-0.4142884126490727/node
      Yarn: 1.22.4 - /var/folders/9g/3kj7knmj46d0bwh4rsj44fd00000gn/T/yarn--1587528255776-0.4142884126490727/yarn
      npm: 6.13.4 - ~/.asdf/installs/nodejs/12.14.0/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
      Android Studio: 3.5 AI-191.8026.42.35.5791312
      Xcode: 11.4.1/11E503a - /usr/bin/xcodebuild
      expo: ^37.0.0 => 37.0.6 
      react-native: => 0.61.4 

Looking through the build logs I’ve noticed that my codesigning_identity and export_options.provisioningProfiles has remained the same through all my failed builds output despite me clearing credentials multiple times. It seems when my builds were passing earlier this would be different between builds?

Also just before these failed builds started, I had a successful build, but when trying to load into test-flight I would get the following error:

ERROR ITMS-90034: “Missing or invalid signature. The bundle ‘XXX’ at bundle path ‘Payload/’ is not signed using an Apple submission certificate.”

Alright, finally resolved after losing a day.
After getting the above error I used biuld:ios -c to regenerate credentials.

However it seems that because I’m not the owner of the team account, it was not using the credentials that I was providing, instead in continued to use the same credentials.

Logging into the owner account, I was able to regenerate certificates.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.