Shortcut keyboard not working in IOS SIMULATOR ?

xpo CLI 3.20.1 environment info:
OS: macOS 10.15.4
Shell: 5.7.1 - /bin/zsh
Node: 12.14.1 - /usr/local/bin/node
Yarn: 1.22.4 - ~/.yarn/bin/yarn
npm: 6.13.7 - /usr/local/bin/npm
Android Studio: 3.5 AI-191.8026.42.35.6010548
Xcode: 11.4.1/11E503a - /usr/bin/xcodebuild
expo: ^37.0.8 => 37.0.8
react: 16.9.0 => 16.9.0
react-dom: ^16.9.0 => 16.13.1
react-native: => 0.61.4
expo-cli: 3.20.1

The Shortcut keyboard not working in IOS SIMULATOR ? when i type CMD + D or CMD+R it works 1/10000 .

When i go to SIMULATOR => I/O => INPUT => SEND KEYBOARD INPUT TO DEVICE and activate it it’s work good , but when i leave the windows of simulator or minimize it , the settings auto disable ?

Old version expo was working without any issues ! Any idea ?


I have the some problem.

I have some problem too. :sob:

Its annoying as hell, someone should look into it.

I am experiencing the same issue unfortunately.
In the mean-time, I have found a work-around, it’s not the best but it works.

When in ios simulator & CMD+D or CMD+R is not working, I’ve found that if you begin to pull down the notifications area (pull down from the top of iphone / notch area) you don’t have to pull down completely, just until some UI becomes visible, and then afterwards you can use the shortcuts.

It’s still a pain to have to do this, but I hope this helps some of you.


This is strange and frustrating. Thanks for the workaround @vctr.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.