SecureStore promises return undefined after upgrading expo-cli to 3.8.0 from 3.4.1

Please provide the following:

  1. SDK Version: 33
  2. Platforms(Android/iOS/web/all): iOS/Android

Right after upgrading expo-cli to version 3.8.0 from 3.4.1, my SecureStore promises are returning undefined.

It affects the logic that I use in many places in my components for reauthentication to access or edit information. This logic worked since April when I developed with SDK 32, and now does not work. The console.logs at the end just return
undefined undefined undefined. Is there something wrong with the way I’ve written my code, or did upgrading expo-cli really break something, such as Expo’s access to the keychain?

I tried running Erase all contents and settings on my iPhone simulator in case it helped, but no dice.

const keys = await ["id", "email", "auth_token"];
    const promises = (key, idx) => {
      console.log(`Working on ${key}`);
      return await SecureStore.getItemAsync(key);

    await Promise.all(promises);

    console.log(promises[0]["_55"], promises[1]["_55"], promises[2]["_55"]);

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.