SDK37 - only crashes on iOS build after seconds and dev is totally fine?

Hi Everyone,

I’ve refrained from reaching out until I was totally out of options.

Things I have tried from reading similar occurrences on the web.

The only possible thing I could see similar was the mention of iOS crashing when trying to store non string values in AsyncStorage. Everything I am saving in AsyncStorage is JSON.stringify-ed. I don’t do this in my app… I only save JSON strings.

The app works flawlessly using the Expo client, on any version of iOS.

I even ran expo build:ios -t simulator and loaded the app directly onto a simulator… still works great.

I upgraded from sdk34 - but this is the first time I am building an expo app… so wouldn’t know if this was working on iOS on SDK34… I following the migration plan and upgraded the SDK in steps. I’m pretty sure that this isn’t an issue. But worth mentioning.

I am stumped… the lack of errors is just not helping.


  "expo": {
    "name": "Kinde",
    "icon": "./assets/ios_launch_icon.png",
    "version": "1.2.3",
    "name": "Kinde",
    "scheme": "kinde-app",
    "slug": "werarekinde-kinde",
    "privacy": "unlisted",
    "sdkVersion": "37.0.0",
    "platforms": [
    "version": "1.2.3",
    "orientation": "portrait",
    "splash": {
      "image": "./assets/kinde_splash.png",
      "resizeMode": "cover",
      "backgroundColor": "#ffffff"
    "updates": {
      "fallbackToCacheTimeout": 0
    "assetBundlePatterns": [
    "ios": {
      "supportsTablet": false,
      "bundleIdentifier": "xxxxxxxxxxxxxxxxxxxx",
      "buildNumber": "3"
    "extra": {
      "firebaseConfig": {
        "apiKey": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx",
        "authDomain": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxx",
        "databaseURL": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx",
        "projectId": "xxxxxxxxxxxxx",
        "storageBucket": "xxxxxxxxxxxxxxxxxxxxxxxxx",
        "messagingSenderId": "xxxxxxxxxxxx",
        "appId": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx",
        "measurementId": "xxxxxxxxxxxx"
    "description": "Kinde Social Media App - Improving the everyday lives"

and this is my package.json file

  "name": "Kinde",
  "version": "1.2.0",
  "description": "Kinde is a social media app focusing on mental helath and connecting people.",
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "eject": "expo eject",
    "svg": "npx @svgr/cli --native"
  "dependencies": {
    "@expo/vector-icons": "^10.0.0",
    "@react-navigation/bottom-tabs": "^5.1.1",
    "@svgr/core": "^5.0.1",
    "buffer": "^5.5.0",
    "expo": "^37.0.0",
    "expo-asset": "~8.1.4",
    "expo-file-system": "~8.1.0",
    "expo-font": "~8.1.0",
    "expo-image-picker": "~8.1.0",
    "expo-linear-gradient": "~8.1.0",
    "expo-localization": "~8.1.0",
    "firebase": "7.9.0",
    "galio-framework": "^0.6.1",
    "global": "^4.4.0",
    "moment": "2.24.0",
    "npx": "^10.2.1",
    "prop-types": "^15.7.2",
    "react": "16.9.0",
    "react-native": "",
    "react-native-base64": "^0.0.2",
    "react-native-gesture-handler": "~1.6.0",
    "react-native-keyboard-accessory": "^0.1.10",
    "react-native-modal-dropdown": "^0.6.2",
    "react-native-svg": "11.0.1",
    "react-native-vector-icons": "^6.6.0",
    "react-native-webview": "8.1.1",
    "react-navigation": "^3.11.0"
  "devDependencies": {
    "babel-preset-expo": "^8.1.0"
  "keywords": [
    "Kinde Mental Health",
    "Kinde Mental Health app",
    "Mental Health",
    "Kinde iOS",
    "Kinde Mental Health native iOS",
    "david pereira",
    "Kinde Android"
  "author": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx",
  "license": "Copyright 2020, all rights reserved.",
  "bugs": {
    "url": ""
  "homepage": "xxxxxxxxxxxxxxxxxxxxxx"

Any ideas how I could debug this?
The pain of making a change in the code and waiting up to an hour to build and launch this in Test Flight is really making it hard as to try different theories.

Any help would be greatly appreciated. Literally - the last step in launching this too!!

Partially solved - at least the app. doesn’t crash anymore. :slight_smile:

If anyone else is having something like this - it could be due to the use of FlatLists

It’s really a problem - so much so, actually moving back to ScrollView the moment I can. Gutted, as the infinite scroll callbacks are great… but the performance FlatList wise is appalling. :frowning:

I ran through a bunch of optimisation configurations - and the app doesn’t crash - but it is super laggy/jumpy. Scrollview though is super smooth. heh

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.