[SDK34] local authentication error in expo app

*It works fine for standalone apps.
However, when I run local in expo app for development, I get the following error.

[Unhandled promise rejection: Error: An exception was thrown while calling `ExpoLocalAuthentication.authenticateAsync` with arguments `(]
- node_modules/react-native/Libraries/BatchedBridge/NativeModules.js:155:41 in createErrorFromErrorData
- node_modules/react-native/Libraries/BatchedBridge/NativeModules.js:104:55 in <unknown>
- ... 5 more stack frames from framework internals

here is my CODE:

let options = {
      promptMessage: i18n.t("MSG_LOGIN_NOFINGER_TITLE")

let authenticationResult = await LocalAuthentication.authenticateAsync(options);
let authenticationError = authenticationResult.error;
let authenticationSuccess = authenticationResult.success;

// after then login process

and where does it change when you feed this option? I thought the message in the prompt would change, but it didn’t apply.

promptMessage (string) -- A message that is shown alongside the TouchID or FaceID prompt. (iOS only)```

Hey @chanho,

This looks to be correctly implemented. Could you create a Snack that reproduces this error so we can try to debug it on our end?


hey @adamjnav,

Sometimes i had same error, i created a project to my studies project and put it on Snack

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.