SDK30 -> SDK32 Map Custom Marker Performance Issues

I upgraded from SDK30 to SDK32 to remove the READ_SMS permission required by the play store. My stand alone android app is now running excruciatingly slow. My main screen is a map view and if there are multiple custom markers shown all tabs run extremely slow, panning on the map is slow. If i initialise the map somewhere with no markers the app runs fine until some markers are loaded. Not much else has changed other than the SDK update

“dependencies”: {
“axios”: “^0.16.2”,
“crypto-js”: “^3.1.9-1”,
“expo”: “^32.0.0”,
“lodash”: “^4.17.4”,
“moment”: “^2.19.1”,
“react”: “16.5.0”,
“react-native”: “”,
“react-native-elements”: “^0.17.0”,
“react-native-geocoding”: “^0.2.0”,
“react-native-google-places-autocomplete”: “^1.3.9”,
“react-native-hyperlink”: “^0.0.14”,
“react-native-image-zoom-viewer”: “^2.0.19”,
“react-native-keyboard-aware-scroll-view”: “^0.7.1”,
“react-native-modal”: “^4.1.0”,
“react-native-modal-filter-picker”: “^1.3.0”,
“react-native-side-menu”: “^1.1.3”,
“react-navigation”: “^2.18.2”,
“react-redux”: “^5.0.6”,
“redux”: “^3.7.2”,
“redux-thunk”: “^2.2.0”
“devDependencies”: {
“babel-preset-expo”: “^5.0.0”,
“eslint-config-airbnb”: “^16.1.0”,
“eslint-config-rallycoding”: “^3.2.0”

I am experiencing almost the same issue. My app’s main screen also contains full screen react-native-maps.
I upgraded from expo v25 to v31 and then to v32 two days ago.
When my app was based on v25, moving and zooming map when there are about 200 markers worked well. If there are more than 300 markers, it was not responsive.

After upgrading to v31, map becomes very slow even with 100 markers. This only happens at Android. As a result, I am not able to release my app before this performance issue get resolved.
I expected this issue be solved by upgrading from v31 to v32, but this issue still happens.
I built apk and internally released to PlayStore, but this issue still happens.

Yeah sounds the same, even with 10+ markers I’m experiencing slow down though. I’m using SVG images to generate basic arrow and circle markers. Might try using Icons and text to see if that helps, but it is definitely only a recent problem

Issue also raised here

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.