sdk 38 >>> error: unknown option `--assetExts'

Please provide the following:

  1. SDK Version: 38

I just update expo to 38 and now, when a i do expo start a get

Opening DevTools in the browser… (press shift-d to disable)
error: unknown option `–assetExts’

Metro Bundler process exited with code 1
Error: Metro Bundler process exited with code 1
at ChildProcess. (/@expo/xdl@57.9.20/src/Project.ts:1857:16)
at Object.onceWrapper (events.js:422:26)
at ChildProcess.emit (events.js:315:20)
at Process.ChildProcess._handle.onexit (internal/child_process.js:275:12)

do you know why ?


thx to an other post, i had :

 "assetExts": [

in my conf. i removed IT and now it’s working.


I get this error, where to add this assetExts ?

in the app.json

thank you, Error gone after upgrading expo-cli

Hi I am getting the same problem, but i dont have assetExts in my app.json but still getting this -

please the issue in detail here - can you please help

1 Like

I did not have any assetExts in my app.json neither. Upgrading expo-cli worked fine.

what version of expo-cli did you upgrade to?
I tried installing it via command npm install -g expo-cli, but that gives errors while installing.

I am still getting the error when i run the command expo start. The error is error: unknown option `–assetExts’ . I do not have --assetExts in my app.json.

Yes, same here I’ve updated expo-cli and still given me the same error. I’m very new to React-Native and would really appreciate the help

I figured it out. Thanks!

Hi rohit1234,

Double check your app.json I thought I didn’t have it the first time but after a good night rest I doubled checked and it was there. I simply removed the assetExts and now my application works!

Hello i try to add or remove this

“assetExts”: [

its stil the same
by default my app.json doesnt have it

Upgrading expo-cli, solved my problem.
Thank you

I upgraded expo-cli to the latest version, expo to to 38.0.0 and an issue still exists. Does any body have the same trouble? If it is, please tell me how you have fixed it.

1 Like

I have the same issue here, I am looking forward your help

What i did, it’s just remove the content in “packagerOpts” from app.json file.

si i have in app.json

"expo": {
    "packagerOpts": {

Hi, that is not solution for me, because when I clean content “packagerOpts”, it generates another error with a loading of svg across the whole project.

same error after update to new expo-cli 3.27.14

See if doing this helps to figure it out:

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.