SDK 33 broken on android and in general?

I have encountered several severe problems on Android standalone build after moving to SDK 33 up to the point it’s unusable and forces me to downgrade.
This includes issues with camera, barcode scanner (still investigating) and Segment analytics. I’ve also encountered problems with animated-switch-navigator (depends on react-native-reanimated and works fine on iOS but breaks on android) and some minor bugs as well.
This is strange given that iOS standalone build and Android expo application can handle all this just fine. Seems like the problem is with standalone build process on android rather on SDK 33 itself.

So the point is - will this problem be addressed in near future, before SDK 34 release? Does it solvable without detaching and if so - how?

1 Like

I got same issues.

Hi @tuankiet1708 and @romanonthego- sorry you’re having trouble

Could you elaborate on what the issues are? If you do think you’ve found a bug, please file an issue on our Github (providing all the info we ask for- especially a repro!)

I am also experiencing issues when compiling expo-camera on android. I am running a expokit project, sdk 33.

error: cannot find symbol method pausePreview()
error: cannot find symbol method getAvailablePictureSizes(AspectRatio)
error: cannot find symbol method getCameraId()

I got the following issue when installing the standalone app on Android:
“Application main has not been registered. …”

But when i downgrade to old version of Expo (version 32), rebuild the standalone app then reinstall on Android, it works ok.


This could be the result of you building your binary while we temporarily had custom builds enabled and thus the unimodules package was not installed as it would normally be. Could you try updating your expo-cli version if it isn’t already updated and then building a new binary?


1 Like

Thanks for your support. I will try doing as you suggest.

I still get problems with the standalone application on Android.

I tried upgrading Expo SDK 33, and run in local with production mode, but got an error as below:

Here is a screenshot of an error on Android (standalone application built with “expo build:android”):

Here is some packages of Expo. Do I need to install seperate modules of Expo?

I’m temporarily using Expo SDK 32 and everything is ok.

Thanks, I can confirm that later this week one of the android standalone build just fixed issues for us - all of missing native modules just appear back (well, at least segment and camera for sure) where they should be. We did however recreated application with new bundle id and install it through google play this time - it may or may be related to fixing an issue.

For future references - thats what fixed issue for us:

  1. i did deleted standalone build application from android phone.
    1.1) i did restart phone (probably not relevant, just force of habit)
  2. i did create new standalone build with sdk33 and new bundle id (application id? Dont remember how id param is called for android)
  3. install newly created application on android phone. Everything start to seems fine again.
  4. upload the same build to google play and testers and logs confirmed that this particular build did work, segments analytics sees events etc.

Hey, does anyone know about the error “cannot find symbol method getCameraId()” while building the application? You guys are discussing after build problems. I cannot even build the app in android studio after upgrading to SDK 33.
PS: I’m using expokit. Platform: Android

Cleaning the project and restarting android studio worked for me

Do you see a android/maven directory in your project? Try removing it

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.