Scan QR Code Missing!

On your latest version 2.4.2 the “Scan QR Code” is now gone?!?!?

Please advise ASAP.

Thank you


The App Store version of the Expo iOS client recently had to remove the QR code scanner from the app. If you intend to load your app on a physical iOS device, please use exp send with exp, the “Send” button with XDE, or the “s” hotkey with create-react-native-app to send your project development URL to your phone by SMS or email.

Read more at Upcoming Limitations to iOS Expo Client | by Ben Roth | Exposition. We apologize for any inconvenience this may cause you!


I use create-react-native-app, but I don’t have an ‘s’ hotkey available. How do I upgrade and can I upgrade already existing projects? I have it working using the XDE, but I’d rather use ‘yarn start’ from the terminal and press an s key.

1 Like


1 Like

First, let me state that I absolutely love Expo, it came just in time before I started mobile development, and frankly I wouldn’t be sure if I would be developing mobile apps if it wasn’t for expo.

This news is quite a bummer. Last week, my client could demonstrate an Work-In-Progress to 50 clients by simply showing a QR code on their slides. It worked in one go on 46 of 50 devices, the other 4 were probably errors on their side. My client and my client’s clients were loving it.

I understand this is Apple’s choice and not Expo’s, and I feel that the way you guys solved it was probably the best available.

Still, I feel that I could have been better informed in advance, for example by generating a warning every time I tried to use the QR scanner on iOS.

If this “sudden”** change would have happened a week earlier, my client would have had 50 disappointed customers AND I would not have known how to solve it immediately.

Anyway, I know you must be working incredibly hard to make this tool work, and I love it every day I use it, I just wanted to share this thought.

Keep up the great work!

**to me, at least


Thanks! For others who would like to copy-paste: yarn add react-native-scripts@1.12.0

1 Like

I have a problem with new version XDE and expo…

in iOs when send a link and try to open the project doesn’t work… stay in splash screen!

in android work fine

whats appen in ios?


You can scan the QR code with the Camera APP (or any other scanner I guess) if you are on ios 11 and tap the notification that comes up!


I am also getting the same issue, with latest version os Expo Client for IOS, app is stuck in Splash Screen

1 Like

Same problem here :frowning: white screen

Same problem :frowning: stuck in Splash Screen

Expo team, please solve this issue, I am unable to work :frowning:

If possible kindly provide us IPA file for Version 4.2.0

i have the same problem… i write the email to but for now nothing info…

What’s the reason? This is a real bummer :face_with_head_bandage: Time to get an Android…

1 Like

not have a info from support :frowning:

@timurbakibayev @anilhurmuz were you also using XDE and the send project link, same as @izzusan?
What logs do you see in XDE (or whatever you were using?)

there isn’t log… in xde and exp… make correct the link but whrn tap in the link remain just the splash screen

This is my link XDE :

i try to replace with:

but nothing

I think this is the issue we’re tracking here:

I can open my app on iphone by sending link to my email and open it on phone.
But I cannot see the live reload and hot reload, debugging expo menu.

Just refresh and goto expo home, something like that?

Can’t we debug from 2.4.2?
Or is there no way to debug from browser and enable live reloading?
I am not on mac, so I am not working on xcode to test iphone, but used to test it on real phones.

Please advice.

Thank you