Run gradlew -> Error: Execution failed for task ‘:expo-updates:kaptReleaseKotlin’

I upgraded the expo SDK to 44 and now I can’t get my app to build using EAS. I get the following error:

...
> Task :expo-updates:kaptGenerateStubsReleaseKotlin
> Task :expo-updates:kaptReleaseKotlin FAILED
[stderr] FAILURE: Build failed with an exception.
[stderr] * What went wrong:
[stderr] Execution failed for task ':expo-updates:kaptReleaseKotlin'.
[stderr] > A failure occurred while executing org.jetbrains.kotlin.gradle.internal.KaptExecution
[stderr]    > java.lang.reflect.InvocationTargetException (no error message)
[stderr] * Try:
[stderr] Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
[stderr] * Get more help at https://help.gradle.org
[stderr] BUILD FAILED in 11m 25s
Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/6.9/userguide/command_line_interface.html#sec:command_line_warnings
471 actionable tasks: 471 executed
Error: Gradle build failed with unknown error. Please see logs for the "Run gradlew" phase.

Here is my package.json:

{
  "scripts": {
    "start": "react-native start",
    "android": "react-native run-android",
    "ios": "react-native run-ios",
    "web": "expo start --web",
    "eject": "expo eject"
  },
  "dependencies": {
    "@aws-amplify/pubsub": "^3.2.28",
    "@babel/preset-env": "^7.1.6",
    "@expo/vector-icons": "^10.2.0",
    "@react-native-async-storage/async-storage": "~1.15.0",
    "@react-native-community/netinfo": "7.1.3",
    "@react-native-picker/picker": "2.2.1",
    "aws-amplify": "^3.3.27",
    "aws-sdk": "^2.572.0",
    "bcryptjs": "2.4.3",
    "buffer": "^6.0.3",
    "expo": "^44.0.0",
    "expo-av": "~10.2.0",
    "expo-barcode-scanner": "~11.2.0",
    "expo-camera": "~12.1.0",
    "expo-constants": "~13.0.0",
    "expo-dev-client": "~0.8.0",
    "expo-image-manipulator": "~10.2.0",
    "expo-keep-awake": "~10.0.1",
    "expo-local-authentication": "~12.1.0",
    "expo-localization": "~12.0.0",
    "expo-random": "~12.1.1",
    "expo-secure-store": "~11.1.0",
    "expo-splash-screen": "~0.14.1",
    "expo-status-bar": "~1.2.0",
    "expo-updates": "~0.11.4",
    "graphql": "0.11.0",
    "graphql-tag": "^2.10.1",
    "i18n-js": "^3.8.0",
    "lodash.clonedeep": "^4.5.0",
    "lodash.isequal": "^4.5.0",
    "moment": "^2.24.0",
    "moment-timezone": "^0.5.27",
    "react": "17.0.1",
    "react-dom": "17.0.1",
    "react-native": "0.64.3",
    "react-native-dialog": "^5.6.0",
    "react-native-gesture-handler": "~2.1.0",
    "react-native-nfc-manager": "^3.9.0",
    "react-native-reanimated": "~2.3.1",
    "react-native-screens": "~3.10.1",
    "react-native-section-list-get-item-layout": "^2.2.3",
    "react-native-table-component": "^1.2.1",
    "react-native-unimodules": "~0.15.0",
    "react-native-web": "0.17.1",
    "react-redux": "^7.1.3",
    "redux": "^4.0.4",
    "redux-logger": "^3.0.6"
  },
  "devDependencies": {
    "@babel/core": "^7.12.9",
    "babel-preset-expo": "9.0.1"
  },
  "private": true,
  "name": "---",
  "version": "1.0.0",
  "resolutions": {
    "**/expo-modules-core": "~0.6.3"
  }
}

I have tried deleting node_modules folder and re-installing but the issue persists.

Anyone have any ideas?

Hey, did you find anything? I am facing this same issue here.

Hi

What is the purpose of the above?

As far as the error is concerned, I’m not sure what the problem is, but googling the error turns up a possible solution: Compile with JDK 11 instead of 8.

You can do this by setting the “image” option to “latest”: