Run Expo Web build locally


We need to self host Expo Web, but having trouble getting it running locally.

What we’ve tried:

expo init
# choose TS blank template
expo start:web

The above works.

Then doing:

expo build:web
serve web-build

Gives a blank screen, with the following in the console:

Uncaught TypeError: Cannot read property ‘call’ of undefined
at f (runtime~app.2dbaae62.js:1)

What am I doing wrong?


Not sure what we’re doing differently, but I followed your steps and it worked for me. The only difference is instead of serve web-build I ran cd web-build; python -mSimpleHTTPServer

I’m running expo-cli version 3.2.3. This was on Linux, although I wouldn’t expect that to make a difference.

Maybe post the output of expo diagnostics?

Thanks for the help. It was a service worker issue. It was displaying a cached page from a different project that was broken. Trying again now and it worked fine when running serve web-build.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.