Roll Back to expo-cli 40

I have an older iPhone for testing, but it can’t upgrade to SDK41, I’ve uninstalled it and deleted the .expo folder from my Linux machine, then tried
npm install --global expo-cli@40
but I get an error saying that the version doesn’t exist.
So how do I pin to an older version?
I tried
sudo npm install --global expo-cli@4.4.0
and I’m still getting expo 41.0.0

I’ve found the template tags, but regardless of various versions, it keeps telling me they don’t exist
expo init --template expo-template-tabs@sdk-40.0.1 forty --npm
expo init --template expo-template-blank@sdk-37.0.1

ok, finally found it

expo init --template expo-template-tabs@sdk-40 --npm

The expo-cli version number is completely separate from the Expo SDK version number.
I was confused by the various different version numbers to begin with, but I got used to it :slight_smile:

I’m glad you figured out the solution.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.