[Resolved] StandAlone app camera not working on iOS (Testflight)

Hello everyone,

I am facing an strange issue, I tried to use expo AR to build a simple AR app on iOS. everything worked properly in the expo app during development. This is using the camera as background and adding cubes. pretty simple.

But after, I wanted to build the standalone app to have it and test it on my phone, but I never manage to have it work. I have the app with a red background and “Unknown error” written in the center.

I checked my phone log to try to track the issue, here what I have:

|error|07:06:54.821827 +0200|ComRaphaelgoncalvesArproject|nw_protocol_boringssl_get_output_frames(1301) <private>[0x107e01980] get output frames failed, state 8196|
|error|07:06:54.821883 +0200|ComRaphaelgoncalvesArproject|nw_protocol_boringssl_get_output_frames(1301) <private>[0x107e01980] get output frames failed, state 8196|
|error|07:06:54.822151 +0200|ComRaphaelgoncalvesArproject|TIC Read Status [5:0x0]: 1:57|
|error|07:06:54.822202 +0200|ComRaphaelgoncalvesArproject|TIC Read Status [5:0x0]: 1:57|

Here are screenshots from the the standalone one (see that only the part where the Camera is supposed to be displayed is red with that message error).

If it helps, here is the project I built locally:

I search for a solution for quite some time, and with no success so far :frowning:
Thank you for your help!

This is a networking error (see this for a similar “TIC” error), so it’s a little strange. Not quite sure what that has to do with the camera. However if I search for the error I find references to Firebase. There’s also an issue with the FaceDetector that was logged recently that apparently requires some Firebase config for standalone iOS apps these days.

Maybe that issue and your issue are related, in which case maybe something in the comments will help you:

1 Like

Hello @wodin thanks for your reply,

Actually someone on twitter answered me and stated that I need to eject the app to add the AR library, which is not included in the Expo built standalone app.

I also found that: Detaching to ExpoKit in order to add AR (SDK 28) so I will give it a try during the week end, and will keep the topic updated about my advancement :slight_smile:

1 Like

OK, good luck :slight_smile:

I’m still not sure why you were getting a networking error, but maybe that was unrelated to the AR issue.

Just did it, I added “AR” to the podfile, and worked like a charm. This is resolved :slight_smile:

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.