[resolved] expo android client app is broken

The Expo Android client app used to work great. Then suddenly it won’t start anymore. It gives me an error log with 2 entries:

  • Uncaught Error: Module AppRegistry is not a registered callable module (calling runApplication)
  • Uncaught Error: undefined is not an object (evaluating ‘c.default.EVENT_NAME’)

I’ve tried uninstalling and re-installing the app (and restarting the phone), but the error remains.

1 Like

I’ve cleared all the local data. That solved the problem


Clearing the local data also solves the problem for me. But the annoying thing is that I have to do it every time that I start the application. Is there anyway to not have to do it every time?

Download older version of apk, I downgraded expo client apk to V 2.9.2 and it’s working fine now

1 Like

I thought I was the only one having this issue I also did rebuild and clearing cache none of them works. For me, I downgraded to 2.10.1. I’m using SDK v32.0.0 and it works fine now.


Got the sampe problem

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.