Request failed with status code 404 (expo publish/expo build)

•100% ➜ expo diagnostics

Expo CLI 3.0.10 environment info:
OS: Linux 4.17 Ubuntu 18.04.3 LTS (Bionic Beaver)
Shell: 5.4.2 - /usr/bin/zsh
Node: 8.10.0 - /usr/bin/node
Yarn: 1.17.3 - /usr/bin/yarn
npm: 6.11.3 - /usr/local/bin/npm
expo: ^34.0.1 => 34.0.4
react: 16.8.3 => 16.8.3
react-native: => 0.59.8
react-navigation: ^3.0.9 => 3.10.1
expo-cli: 3.0.10

Hello community! Lately I’m having a mistake, could you please help me!The problem is that I cannot upload my bundle js to Expo servers.
Every time I try to make an expo publish or expo build I get the following error:

•100% ➜ expo publish
Unable to find an existing Expo CLI instance for this directory, starting a new one…
Starting Metro Bundler on port 19001.
Tunnel ready.
Publishing to channel ‘default’…
Building iOS bundle
Finished building JavaScript bundle in 4665ms.
Building Android bundle
Finished building JavaScript bundle in 3725ms.
Analyzing assets
Finished building JavaScript bundle in 4379ms.
Finished building JavaScript bundle in 4747ms.
Uploading assets
No assets changed, skipped.
Processing asset bundle patterns:

  • /home/cronos/WORKDIR/influenceMeNow/**/*
    Uploading JavaScript bundles
    Request failed with status code 404
    Error: Request failed with status code 404
    at createError (/usr/local/lib/node_modules/expo-cli/node_modules/axios/lib/core/createError.js:16:15)
    at settle (/usr/local/lib/node_modules/expo-cli/node_modules/axios/lib/core/settle.js:17:12)
    at IncomingMessage.handleStreamEnd (/usr/local/lib/node_modules/expo-cli/node_modules/axios/lib/adapters/http.js:237:11)
    at emitNone (events.js:111:20)
    at IncomingMessage.emit (events.js:208:7)
    at endReadableNT (_stream_readable.js:1064:12)
    at _combinedTickCallback (internal/process/next_tick.js:138:11)
    at process._tickCallback (internal/process/next_tick.js:180:9)

I have tried to minimize my bundle js as much as possible, while I have removed the files that I had in my assets and have taken it to a folder within the components of the application, the distribution of the weight has been as follows:

•100% ➜ du -mhsc *
2.2M amplify
8.0K App.js
4.0K app.json
16K assets
4.0K aws-exports.js
4.0K babel.config.js
4.0K bash.exe.stackdump
22M components
452M node_modules
4.0K package.json
488K src
44K store
328K yarn-error.log
292K yarn.lock
477M total

I use Git for the versioning of the application, I have noticed that in previous versions I have been able to upload the testflight application without problems, but I do not understand how it is possible, if in those versions the bundlejs is much, but much larger than the version I try to upload (Almost reaching 1GB).
I have also tried to upload the bundle with different accounts and I have not been successful

Run expo export ---public-url <any_https_url> and check size of bundle and assets in dist directory

1 Like

Hi @wkozyra, here the sizes :slight_smile:

•100% ➜ du -mhsc dist/*
16K dist/android-index.json
4.2M dist/assets
35M dist/bundles
16K dist/ios-index.json
39M total

Can close the case, I have solved it by decreasing the size of my bundlejs

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.