Remove NSUserTrackingUsageDescription

I’m using eas build and in managed workflow
my app.json files doesn’t include NSUserTrackingUsageDescription but when I build the app and want to publish it to the app store apple say that Your app contains NSUserTrackingUsageDescription.
can every one help me to remove this permission from my app?
thanks

what does your package.json and app.json look like?

I’m having the same issue, using EAS, NSUserTrackingUsageDescription is set in Info.plist with a default message and Apple didn’t like that. We aren’t using expo-tracking-transparency.

Attribute in our info.plist (generated using expo eject):

<key>NSUserTrackingUsageDescription</key>
<string>This identifier will be used to deliver personalized ads to you.</string>

app.json and package.json files:

Is there a way to more granularly configure the eject output within EAS?
Thank you in advance for you assistance.

Hello
I have the same question: How to remove/disable NSUserTrackingUsageDescription from expo project?

expo 5.0.3
eas-cli/0.46.0 win32-x64 node-v12.14.0
Windows 10

Build for IOS made by eas build/update.
Apple says: Your app contains NSUserTrackingUsageDescription, indicating that you will request permission to track users. To publish this information on your app’s product page, you must indicate which data types are tracking users. If this is incorrect, update your app binary and upload a new build to App Store Connect..

But I can’t find where to configure this option. I did not added NSUserTrackingUsageDescription at all.

app.json

"expo": {

        "name": "sm24",
        "slug": "sm24",
        "owner": "sendmoney24",
        "version": "2.0.46",
        "orientation": "portrait",
        "icon": "./assets/icon.png",
        "facebookScheme": "fb223236666007562",
        "facebookAppId": "22323626667562",  
        "facebookDisplayName": "Sendmoney24",
        "splash": {
            "image": "./assets/splash_2.png",
            "resizeMode": "contain",
            "backgroundColor": "#1b3752"
        },
        "updates": {
            "fallbackToCacheTimeout": 0
        },
        "assetBundlePatterns": [
            "**/*"
        ],
        "ios": {
            "bundleIdentifier": "com.geperson.sm24a",
            "config": {
                "googleSignIn": {
                  "reservedClientId": "com.googleusercontent.apps.947949772221-3hp90qsaj56u66eol57873acj3toe34k"
                }
            },
            "supportsTablet": true,
            "buildNumber": "2.0.46",
            "googleServicesFile": "./GoogleService-Info.plist"
        },
        "android": {
            "package": "com.sendmoney24.sm24a",
            "versionCode": 46,
            "googleServicesFile": "./google-services.json",
            "adaptiveIcon": {
                "foregroundImage": "./assets/icon.png",
                "backgroundColor": "#FFFFFF"
            }
        },
        "web": {
            "favicon": "./assets/favicon.png"
        }
    }

package.json

{
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject"
  },
  "dependencies": {
    "@eva-design/eva": "^2.1.1",
    "@expo/react-native-action-sheet": "^3.10.0",
    "@mdi/font": "^5.9.55",
    "@mdi/js": "^5.9.55",
    "@mdi/react": "^1.5.0",
    "@react-native-async-storage/async-storage": "~1.15.0",
    "@react-native-community/datetimepicker": "4.0.0",
    "@react-navigation/bottom-tabs": "^6.0.3",
    "@react-navigation/drawer": "^6.1.1",
    "@react-navigation/native": "^6.0.2",
    "@react-navigation/stack": "^6.0.4",
    "@ui-kitten/components": "^5.1.1",
    "@ui-kitten/eva-icons": "^5.1.1",
    "axios": "^0.21.1",
    "chalk": "^4.1.2",
    "currency-symbol-map": "^5.0.1",
    "datejs": "^1.0.0-rc3",
    "eas-cli": "^0.31.1",
    "expo": "^44.0.0",
    "expo-app-loading": "~1.3.0",
    "expo-device": "~4.1.0",
    "expo-facebook": "~12.1.0",
    "expo-google-app-auth": "~8.3.0",
    "expo-google-sign-in": "~10.1.0",
    "expo-image-picker": "~12.0.1",
    "expo-linking": "~3.0.0",
    "expo-local-authentication": "~12.1.0",
    "expo-modules-core": "~0.6.4",
    "expo-network": "~4.1.0",
    "expo-permissions": "~13.1.0",
    "expo-splash-screen": "~0.14.1",
    "expo-sqlite": "~10.1.0",
    "expo-status-bar": "~1.2.0",
    "expo-updates": "~0.11.5",
    "html-react-parser": "^1.4.0",
    "iban": "0.0.14",
    "ibantools": "^3.3.1",
    "js-html-parser": "^1.0.7",
    "mdi-react": "^7.5.0",
    "mime": "^2.5.2",
    "moment": "^2.29.1",
    "react": "17.0.1",
    "react-dom": "17.0.1",
    "react-html-parser": "^2.0.2",
    "react-native": "0.64.3",
    "react-native-actionsheet": "^2.4.2",
    "react-native-animated-icons": "^1.0.5",
    "react-native-app-intro-slider": "^4.0.4",
    "react-native-bottom-action-sheet": "^2.0.2",
    "react-native-gesture-handler": "~2.1.0",
    "react-native-image-helper": "0.0.3",
    "react-native-keyboard-aware-scroll-view": "^0.9.4",
    "react-native-loading-spinner-overlay": "^2.0.0",
    "react-native-modalize": "^2.0.8",
    "react-native-paper": "^4.9.2",
    "react-native-portalize": "^1.0.7",
    "react-native-reanimated": "^2.3.1",
    "react-native-safe-area-context": "3.3.2",
    "react-native-screens": "~3.10.1",
    "react-native-scroll-bottom-sheet": "^0.7.0",
    "react-native-svg": "12.1.1",
    "react-native-unimodules": "~0.15.0",
    "react-native-web": "0.17.1",
    "react-native-webview": "11.15.0",
    "reanimated-bottom-sheet": "^1.0.0-alpha.22",
    "rn-fetch-blob": "^0.12.0",
    "styled-components": "^5.3.0",
    "yarn": "^1.22.17"
  },
  "devDependencies": {
    "@babel/core": "^7.12.9",
    "@types/react": "~17.0.21",
    "@types/react-native": "~0.64.12",
    "typescript": "~4.3.5"
  },
  "private": true
}

Thanks

Hi

The NSUserTrackingUsageDescription is coming from expo-facebook. You can disable this by configuring its config plugin in app.json:

@wodin Thank you very much :+1: