Remove node_modules and then running npm install destroy my Expo project

Hello everyone,

My expo app was working fine on both web and ios. Then, I wanted to deploy it but had the following issue “React-native is not installed”. In order to fix it, I tried to follow advices and do the following:

  1. remove node_modules
  2. npm install
  3. expo start

However, now, my app is still working on the WEB, but on IOS, I have the following error in one of the first pages of the App:

It looks like on IOS, “em” values in Style are not understood anymore.

Below is my package.json, used when I run npm install:

  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject"
  "dependencies": {
    "@react-native-community/masked-view": "0.1.10",
    "@react-navigation/bottom-tabs": "^5.8.0",
    "@react-navigation/compat": "^5.2.5",
    "@react-navigation/native": "^5.7.3",
    "@react-navigation/stack": "^5.9.0",
    "dotenv": "^8.2.0",
    "expo": "~38.0.8",
    "expo-image-picker": "^8.4.0",
    "expo-status-bar": "^1.0.2",
    "modal-react-native-web": "^0.2.0",
    "moment": "^2.27.0",
    "native-base": "^2.13.14",
    "react": "~16.11.0",
    "react-dom": "~16.11.0",
    "react-native": "",
    "react-native-elements": "^2.3.0",
    "react-native-gesture-handler": "^1.3.0",
    "react-native-google-books": "^1.0.4",
    "react-native-keyboard-aware-scroll-view": "^0.9.2",
    "react-native-loading-spinner-overlay": "^1.1.0",
    "react-native-screens": "^2.10.1",
    "react-native-star-rating": "^1.1.0",
    "react-native-web": "~0.11.7"
  "devDependencies": {
    "@babel/core": "^7.8.6",
    "babel-preset-expo": "~8.1.0"
  "private": true

Finally, my node and npm versions:


Thanks a lot for your time.

Hi @nolwww
Did you try cleaning cache expo start -c