Release Channels publish does not update JS on app

I am publishing with release channels exp publish --release-channel staging. Today I have noticed that updates are not pushed to the app which uses a specific release channel which I am pushing to.

Hi @eodow. Can you explain what you’re tried end-to-end?

Hi @eodow, this may be due to a caching bug that we are rolling out the fix for in the near future. In the meantime, I’ve reset our caching system. Could you check that the update is pushed now? Sorry for the inconvenience.


Thanks for the reply, looks like the issues got fixed after @quinlanj reset the cache.

1 Like

Thank you very much, it is fixed now. BTW Android app was updating after each push to the channel normally.

1 Like

Running in to the caching issue again.

@eodow That’s weird. We’ve pushed a fix out recently. Did you publish and not see your app updated?


exp publish --release-channel staging

with updates, does not display them on the app.

Does running exp publish to the default channel work?

Also, does restarting the app update it?

Restarting or reinstalling the app does not pickup updates. I have not tried pushing to default, because its production env. (i guess i can try to push some color change to see if it picks it up)

@eodow i looked up your entries in our caching system, and if you are referring to your standalone app not being able to pick up changes, the reason for that is because your standalone app only supports SDK version 17-23, and it appears that you have been publishing updates for SDK 24. For your changes to appear, try publishing a compatible version (ie) 23 – you can specify sdk version in app.json

1 Like

I have the same issue but I’m using sdkVersion 23.0.0. If I make changes to my .env files and run exp publish to the default channel, I do not see my changes.

@dmongit are you using a babel plugin for the .env file’s values? It’s quite possible that metro (the bundler RN uses) is caching your transform results without rebuilding from the .env changes. There’s a --clear option on publish IIRC, which you can use to publish a fresh build. Might be worth a try.

@dikaiosune yes! I’ve added --clear to my command scripts and testing that now. I ran a straight up exp publish --clear to my default channel and was able to toggle between two instances of the app (one was dev and one was prod). Thanks!

I should be able to produce 3 separate builds (each pointing to a different release-channel bundle), right? I’m not sure how TestFlight works for going back and forth between builds. But, I figure I could build 3 separately configured release apks to install on my Android. I suppose I can only have one installed at a time, but that should work. I hope.

How do I make my standalone app to support version 24? Do I need to build a new apk/ipa file with version 24 for this to work? I need to run on version 24, because it has some fixes I need. Thanks for checking! BTW when you clear that cache on your end I was able to publish changed.

I am still having problems publishing, even to default channel with exp publish command. I have created a new apk and ipa and it was working when I was publishing to a specific channel. This version of the app is not released and changes are not published.

I think I figured out what was wrong. I published binaries which where created with a channel in mind. I was planning to keep this version in testflight, but then realized that I need to redeploy if SDK version changes. Hopefully someone else runs across this and my comments help

My fix was changing the slug name and publishing again.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.