Push Notifications stopped delivering despite 200 response from Expo

For months, I’ve been able to deliver push notifications to our users without a single hiccup. I set up the service as described in the docs and everything.

Today, I went to deliver a notification and everything seemed to work great, including the response I received from Expo’s PN server

performed EASY effective_url=https://exp.host/--/api/v2/push/send response_code=200 return_code=ok total_time=0.196346

None of our users are getting the push notification (iOS/Android) and that’s concerning. I have NO CLUE where to go from here.

I’ve attempted to send a notification in my production environment to my own device, and the status comes back as 200 yet still nothing is actually delivered. What can I do from here to track down the issue?

{"status"=>"ok", "id"=>"5b69bea2-268c-48a9-bf4d-e5153e35a65a"}

Hey @trev91,

Have you changed anything between when push notifs worked and when they didn’t? For example, an SDK upgrade or publishing?

Also, can you let me know what SDK version you are on?


Hey @adamjnav, I did not publishing or SDK upgrades. I’m on Expo SDK v32.0.0.

Still no luck sending them. :confused:

Any idea what we could do to try to debug this?

You could try sending via our Delivery Tool.

I get the “green check” when I click the button to send the notification, but no push notification shows on my phone, or the few other phones I have. Is there a way to see via server logs if anything is failing behind the scenes? @adamjnav

@adamjnav Any other ideas? Not sure what to do next. Push notifications are a huge part of our app and so I’d like to try to get this figured out ASAP.

Also open to other push notification solutions that would be compatible with expo apps.

Solved the problem by renewing our Push Service Certificate with Apple.

Thanks for your time @adamjnav!

Glad to hear you got things remedied! Sorry for the delay…I was traveling so wasn’t very responsive.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.