Push notifications not showing on phones


I have recently upgraded a project from sdk 38 to 40.

Currently im working on the Android side, especifically with the notifications.

After following the docs, and deleting multiple times the Firebase project to discard any errors. I don’t have any clue as to why the notifications are not showing in the phones I’m working on.

I tried the Push notifications tool, and it returns the id and a “ok” status. And when I ask for the receipts, they also return ok

Can anyone help me out to show the push notifications on the phones.


This strongly indicates that you have either misconfigured your credentials, or didn’t configure them at all. In Expo Go, you rely on Expo’s credentials so that you don’t need to worry about it, and setup is as easy as possible. But when you build your own app for the stores, you need to use your own credentials. On iOS, this is handled via your push key (revoking the push key associated with your app will result in your notifications failing to be delivered. To fix that, add a new push key with expo credentials:manager). On Android, all you need to do is follow this guide. Please note that after setting up Android FCM credentials, you will need to rebuild your app.

Expo abstracts the majority of credential management away so that you can focus on building your app, but if you want to understand it on a deeper level, read our guide to app signing.

Thanks for the fast anwser, I already check the expo credentials:manager and the server key is equal to the one in firebase and the android.package property (app.json) is equal to the package name (firebase).

For now I’m testing the notifications in the Expo Go app.

When you said:

In Expo Go, you rely on Expo’s credentials so that you don’t need to worry about it, and setup is as easy as possible

It means that I should be seeing the notifications either way?

yep, it should work in Expo Go without the need for credentials. Can you try this snack and see if it properly triggers a local notification- Push Notifications - Snack

Thanks for the reply, I just tried the snack and it worked. I’m going to check my code.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.