push notification tool not working


the expo push notification tool is not working for me. I’ve tried several snacks (e.g. pushnotifications - Snack) either on the simulator or on my physical phone. Nothing is working. It always shows this error message:


That’s what I entered into the blanks:

Can somebody help me? I’m really clueless about that and I’ve been stuck at this problem for some time now.

Thank you!

Hey @andy1996! Sorry it’s not working for you, that’s odd because I just connected to the Snack with my device to get the push token, sent it to myself and it worked.

What device are you trying this on? Has it worked before on it?

Thank you so much for your reply!

I just saw that only my phone has a problem with notifications. Nothing wrong on your side…

btw. I’ve got an Xiaomi Mi5

Could you try disabling the battery optimization on your device? Looks like that’s a common cause according to these forum posts - one and two :slight_smile:

The problem is that I always get the error message of the notification tool… I don’t know why…

I tested it now with a OnePlus 3 and there, it works fine.

1 Like

What Android version are you running on problem device?

MIUI 10.2, which is based on Android 8.0.0

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.