Push Notification Entitlement Missing in ios build

I have let Expo handle everything I can when building with expo build:ios

I have a proper Distribution Cert and that seems to be working great.

Under App ID, I turned on Push Notifications and made certs:

I have an Expo Key under Keys in Dev portal:

I looked at my provisioning profiles on my device using XCode after installing the TestFlight build, and it shows my profiles are correctly installed for the app ID I am using:

I have tried expo fetch:ios:certs, and it looks like Push P12 Password might be missing? Not sure if thats necessary:

While developing, my app asks for permission, then requests a token from expo, then saves it in the db.

In the standalone app, my app will ask for permission, but then not token is saved in the db. I tried using idevicesyslog to check for console.logs I left in there for debugging, but I guess they don’t trigger in a standalone.

I’m getting an email from Apple saying Push Notification Entitlement Missing

I’m not sure what could be missing here??
Is this caused by the Push P12 Password being “(not available)”?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.