Published app never opens nor errors, just hangs

I published via exp and exp xde and the published link won’t open. The expo app just stays at the splash. I can publish other apps and load those fine. Something is unique wrong about my project code.

I’ll eventually figure this out but curious if someone has tips.

ios and android? I had that issue with ios. I disabled the splash in one of the plist files (sorry, no mac around right now to know which one). the app fired right up.

1 Like

Yeah both iOS and android

exp start --minify

^showed an error about one of my assets/images not found.

I think I fixed it by deleting /.expo and /node_modules and running yarn install again.

Then I got into a host of another set of errors. Below issue is inside react-native , and it affects expo 23 & 24 SDK. I don’t know how anyone can run release/production code with expo 23 & 24. (react-native 0.51.0 & 0.50.3). Therefore I downgraded all the way to expo 22 and now everything publishes.

Another way I solved it was via downgrading uglify-es (an indirect package dependency) and manually changing code in ./node_modules/react-native :

pretty nasty fix IMO - choose your poison.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.