Project that runs fine on Mac did not start on Ubuntu

Hi,

as the title states - I have a small app that works perfectly fine if I start the exp server on Mac - but if I try the same project on Ubuntu I can’t run it on the emulator.
I encounter this issue too: Ubuntu expo Tunnel but I also can’t manage to run it via Localhost nor LAN.

If I start the server via LAN - I get the message:
Uncaught Error: Packager is not running at http://192.168.178.79:19001

I’ve tried it so far with Genymotion and the avd - all Android paths are set and ADB is working fine. Fetching the manifest works from the browser and from the emulator.

Unfortunately I am running out of ideas and would appreciate every help.

Thanks!

It seems like the packager is having trouble starting. Do you have any other error logs that relate to that that you can share?

No, unfortunately there are no more logs than that. At least nothing if I run exp start - c.

Do you have any suggestion where or how I could search for more Infos?

Try setting the environment variable EXPO_DEBUG=true and rerun and see if you get more information. That might help us figure out what’s going on.

Thx for the tip - could you tell me where I can set this variable? should I export in my .bashrc ?

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.