Problems uploading to App Store - App Signing Problems

Hi, I’m facing a problem while uploading the app to the App Store, via application loader. It is a straightforward Expo application (Not Detached). The credentials are all managed by Expo.

The build succeeds and I’m able to download the .ipa file. However there are following problems while uploading.

This is not a new App store upload as the app already exists there. This is merely an update which I want to upload to TestFlight.

Please help me, Not able to figure this out.

I also tried looking at the build logs, and did find some errors there. Not sure if this the actual problem.

Hey @manoj.nama,

You’ll want to revoke your credentials and regenerate them.



I did try that, But facing the same issues still. But I can try one more time though

Tried regenerating the credentials by clearing them out, Managed by Expo. Still same issues.

Also tried generating my own Certificates and Profiles, but facing the same problem.

You should also delete your provisioning profile on apple developer site.

I deleted everything from the Apple developer site, Then let Expo manage the credentials, same issue. Deleted everything, created certificates and provisioning profile manually, still same issue. Please help me out, I’m running out of time on this, and desperately need a solution.

@jakubste @adamjnav Hey Guys, anything you found or any updates??

I’m able to create a build that I can upload By detaching and using the same provisioning profile and Certificates that expo has, So there is something broken on the Expo build process. Unfortunately don’t think anybody has looked into the issue.

Check out DocumentPicker - Expo Documentation
I think there is some misalignment between your app config (in app.json) and Apple credentials regarding icloud services

Double checked, app.json does correctly specify "usesIcloudStorage": true, and iCloud is enabled in Application Services. The docs only mention these two things. FYI the SDK version I’m working on is v27

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.