Problem with GIF animation and EAS build

Hello,

I have a problem with GIF animation with EAS build. GIF animation works as expected in Expo Go app but it is not animated anymore after using eas build commands. I may be wrong but I think it’s because RN needs a dependency (which is already included in Expo Go app) to show GIF animation. How can I solve this problem please?

Thank you

Hi @yzobairi

Yes, I think you’re right. It looks like the following is missing from android/app/build.gradle:

GIF and WebP support on Android

When building your own native code, GIF and WebP are not supported by default on Android.

You will need to add some optional modules in android/app/build.gradle , depending on the needs of your app.

dependencies {
  // If your app supports Android versions before Ice Cream Sandwich (API level 14)
  implementation 'com.facebook.fresco:animated-base-support:1.3.0'

  // For animated GIF support
  implementation 'com.facebook.fresco:animated-gif:2.0.0'

  // For WebP support, including animated WebP
  implementation 'com.facebook.fresco:animated-webp:2.1.0'
  implementation 'com.facebook.fresco:webpsupport:2.0.0'

  // For WebP support, without animations
 implementation 'com.facebook.fresco:webpsupport:2.0.0'
}

I see that someone else reported this and @bycedric wrote a config plugin to do this:

Are you able to see if it works on SDK 43 beta without a config plugin? Based on the other comments in the above issue this is supposed to be fixed in “the next version of Expo”. If it’s still a problem, maybe create another issue to say that it does not work with SDK 43 beta, and point to the above issue.

With SDK 43, we solved this issue in the native code we generate during expo prebuild. It’s now part of the project instead of a separate plugin.

1 Like