Problem with 'expo install'

I have an application with expo here, the application works fine but I can’t run the command ‘expo install’ to install dependencies through the expo.

I already tried running with sudo;
I’ve tried almost everything in this article:

i get this error:

  /snap/node/5782/bin/node /snap/node/5782/bin/yarn.js add expo-font@~10.0.4 @expo-google-fonts/inter


Yarn version: 

Node version: 

  linux x64

  Error: EACCES: permission denied, write
      at writeSync (fs.js:736:3)
      at SyncWriteStream._write (internal/fs/sync_write_stream.js:24:3)
      at writeOrBuffer (internal/streams/writable.js:358:12)
      at SyncWriteStream.Writable.write (internal/streams/writable.js:303:10)
      at Object.cursorTo (readline.js:1328:17)
      at writeOnNthLine (/snap/node/5782/lib/cli.js:49855:14)
      at Spinner.render (/snap/node/5782/lib/cli.js:97560:48)
      at Spinner.start (/snap/node/5782/lib/cli.js:97547:10)
      at ConsoleReporter.activity (/snap/node/5782/lib/cli.js:97093:13)
      at PackageResolver.<anonymous> (/snap/node/5782/lib/cli.js:65580:52)

Hey @jvgs1111, are you able to run any other expo-cli commands?

The only command that doesn’t work is ‘expo install’.
Apparently the problem is with the snap version of node on Ubuntu. I haven’t tried to fix it yet because I have projects in progress. But as soon as I try I’ll update the topic.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.