Problem to connect my Smartphone (Android) to my App (Expo QRcode)

I have a problem to connect my app project on my smartphone. About what I tried to do in order to solve my problem , I think it’s about my firewall configuration but I allow outcome and income connection from address given by expo project but it still doesn’t work .
Here are all information you might need to understand and help me on my issue :

expo app Android client version : 2.18.7
Supported SDKs : 37,38,39,40

Android studio install with snap
Name Version Rev Tracking Publisher Notes
android-studio 101 latest/stable snapcrafters classic

$ Android/Sdk/tools/bin/sdkmanager --list
Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/bind/annotation/XmlSchema
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.annotation.XmlSchema
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(
	at java.base/java.lang.ClassLoader.loadClass(
$ npm -v

Information Linux System

Architecture:                    x86_64
CPU op-mode(s):                  32-bit, 64-bit
$lsb_release -a 
LSB Version:	core-11.1.0ubuntu2-noarch:printing-11.1.0ubuntu2-noarch:security-11.1.0ubuntu2-noarch
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.2 LTS
Release:	20.04
Codename:	focal

###Steps to load my app from my project folder with terminal (script from project React write with Atom) :

npm start
expo start

Starting project at /home/andriac/Documents/Formation/MOOC_React/Project_App_React/MoviesAndMe
Developer tools running on http://localhost:19002
Opening developer tools in the browser...
Waiting on exp://**address:port** 
 › Scan the QR code above with Expo Go (Android) or the Camera app (iOS)

 › Press a │ open Android
 › Press w │ open web

 › Press d │ show developer tools
 › shift+d │ toggle auto opening developer tools on startup (enabled)

 › Press ? │ show all commands

Logs for your project will appear below. Press Ctrl+C to exit.

###Automatically a new tab Firefox opens

Finnaly here are my errors on my App Expo Go (Android phone) when :

  • I scan QR code with connection “LAN” : “Uncaught Error: timed out”

  • If I scan Qr Code with connection “Local” : I get an infinte loading on my Android Expo App with nothing else on screen , just the loading icon (about 30min before to stop)

  • If I try with tunnel connection I get this error on my computer terminal :
    Installing @expo/ngrok@^2.4.3 for tunnel support…
    Tunnel URL not found (it might not be ready yet), falling back to LAN URL.
    Tunnel URL not found (it might not be ready yet), falling back to LAN URL.
    Error starting tunnel Failed to install @expo/ngrok@^2.4.3 globally: npm exited with non-zero code: 243
    Tunnel URL not found (it might not be ready yet), falling back to LAN URL.

and this error on my App Expo “Uncaught Error: timed out”


  • I allow my firewall computer the address given by expo to connect to the app
  • My phone and my computer are connected to the same WIFI network
  • When I disable my firewall the scan QR Code works fine

If you need more information to understand and help me to solve the problem please let me know.
Thank you and have a good day