Problem creating New Project

Greetings. I am a student currently working on a React Native app project for my school and have came across Expo. My current problem is one that I have not seen other users faced where when I click “New Project”, my program will be stuck at the “Extracting project files…” loading screen. I have left it running for more than 12 hours, but from what I see through tutorials this process only requires a couple of minutes. Please help as I cannot proceed from this point on. Thank you :slight_smile:

Hi! welcome to Expo :slight_smile:

Could you give me some more information about your computer? I’d love to help. What OS are you running?

I’m having the same issue.

Windows 10
Node v7.4.0

Edit: I see the templates found in this issue. is there anywhere where i can find the link to the latest one’s as a workaround?

1 Like

Since I can’t reproduce this issue on OSX (I also just updated XDE and verified it worked on both versions of OSX), I’m going to try this on my windows box and see if I can reproduce there)

I’m running on Windows 10.

Seems like our Windows 10 users are running into this issue, This is super useful I’ll try to get back to you guys with a solution as quickly as possible.

Edit: We have a pull request in review that may triage this issue. I’ll update this thread when it lands.

1 Like

I got the same problem when i updated the expo xde to the newest version today. I am using windows 10, node v6.3.1

I got another bug on the expo client on my iphone iOS 9.3 when i updated to newest version from AppStore. I dont know if it is related to this problem or not.

When i opened my previous project which used to work well, and use LAN exp://, i got below error.

I sure i was on the same working network, and i am sure that the error came after i had updated client and server expo.

A couple things you can try are:

  • Force quitting the app on your phone and re-opening it
  • Testing that your phone can access the development server on your computer by visiting http://<the URL in XDE>
  • Clicking Restart in XDE
  • Closing XDE and re-opening it

Thanks ide.

  • My iphone can not access the development server on by visiting http://
  • I have to run XDE on ubuntu, and it works! Therefore, I think the problem is that XDE newest version does not work on Windows 10.

Just for your reference, I have tried many combination, here is the result:

  • The previous version of XDE + previous version of client App → works well on Windows 10.
    The previous version of XDE + newest version of client App → does not work on Windows 10.
  • Newest version of XDE + newest version of client App → does not work on Windows 10.
  • Newest version of XDE + newest version of client App → works well on Ubuntu

I’m having this issue as well, on Windows 10, Node v7.7.3, latest Expo.

I was unsure if it was because my port 8081 was blocked (thanks McAfee), but it seems others are having the issue regardless.

I also had the same issue. node v6.10.3. windows7. Stuck in “Extracting project files” screen.
However I just closed XDE, opend it again, and opened the created project in XDE and it worked. I was able to run the project in android emulator.

Had the same problem. Solved when I ran XDE (2.18.0) as administrator.
OS: Windows 10

Any update on this from somebody who’s maintaining the XDE?

That seems to be the solution. Running as admin fixed the problem on Windows 10 and 2.18.0.


This solution worked!! Many thanks

1 Like