pod install failed with expo-dev-clientand bare workflow

Hi, I‘m in trouble.

I often useing bare workflow, I need a dependency but it only supports Development Builds, So i need to add expo-dev-client, eas device:create it’s going well, I try run eas build --profile development --platform ios then i get a error, Here:

I noticed out-of-date source repos which you can update with pod repo updateor withpod install --repo-update. in failed detail, I try run pod repo update and pod install --repo-update then i get a different error, Here:

I try to change my ios/app/AppDelegate.m from Installation in React Native and Bare workflow projects - Expo Documentation

I run eas build --profile development --platform ios again then i get same error.

I don’t know what to do, Help me please!

Also, Before that I update my SDK from 41 to 45

I delete my native code folder and rebuild, It’s work.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.