Please I am getting this error with eas build

Before posting your question, make sure you’ve read the documentation for both EAS Build & Submit.

If your Android or iOS build is failing- make sure you do your own research on the error message first before posting (this will give you a better understanding, and you might even find that someone else has already solved the issue!) It is not up to the Expo team to debug your project or build.

In your post, please share:

  • Whether you are bare or managed workflow
  • Your eas-cli version
  • What you have tried so far

Please I am getting this error at the run of eas build.

Hi @ayoola222

It looks like you have some sort of permissions problem.

You could try selecting the “C:\Users\USER\forcompile” folder in Windows Explorer and “take ownership” recursively (for that folder and all its children/decendents).

Another possibility is that another process has a file open that the eas build command was trying to write to. This could happen if you have an antivirus that was scanning something when you were running eas build.

@Wodin How , Taking ownership of the folder

Try this: How to Take Ownership of a Folder in Windows 10 Using File Explorer | Laptop Mag