Packager starts then stops silently


I’m trying to run my project with exp but the React Native packager fails silently each time I run `exp start --lan’.

I can see it running with ps -a | grep <packagerPid> right after I run the command but it stops after a few seconds. :frowning:

The output of `exp start --lan’ is

[exp] Starting React Native packager...
[exp] Scanning 529 folders for symlinks in <path>/node_modules (2ms)
[exp] Loading dependency graph.
[exp] Running packager on port 19001.
[exp] Expo is ready.
[exp] You can scan this QR code:

<Qr code>

[exp] Your URL is


[exp] Logs for your project will appear below. Press Ctrl+C to exit.

Does anybody have an explanation?

OS: Fedora 26
sdkVersion: 20.0.0

@ljed can you make sure exp is up to date? Also is your URL reachable? (ie) exp://

I’m using the latest version of exp and exp:// is reachable.

exp -V is 44.0.0.

The error I get on my device is

Could not connect to development server.


In Expo log, I also found

  "msg": {
    "error": {
      "syscall":"watch <path>/node_modules/react-native-maps/lib/android/lib/build/intermediates/exploded-aar/",

I finally solved it by running:

echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p
1 Like

@ljed thanks a thousands time for ur precious post! It saved me actually!

Also helped me on Ubuntu 16.04. Thank you @ljed

This topic was automatically closed after 14 days. New replies are no longer allowed.