OTA Updates Don't Work for IOS

I’ve had an app in the app stores for several months and yesterday morning got approval from Apple for an update (its a stand alone app that I updated expo from v24 to v27)

I updated the app on my iphone around noon, and then several hours later I published an OTA update for the app (a simple icon change - NOT the splash icon, but an icon on an internal screen).

On my android phone the OTA changes were successful, but I cannot get the update on my iphone. I’ve tried closing the app and opening it again several times - but this doesn’t help.
If I go to the url for the published app (https://exp.host/@amweiss/mindful-usc), I can see the changes there.

This is what I have in app.json

"updates": { 
  "enabled": true,
  "checkAutomatically": "ON_LOAD",
  "fallbackToCacheTimeout": 0

Is there something I’m doing wrong here?

What icon are you trying to change? Is it an icon inside your app or an icon specified in app.json?

The icon is a simple icon I’ve used throughout my app from the expo icons directory. I changed words on this screen as well, but those also don’t update.

its a stand alone app that I updated expo from v24 to v27

If you’re trying to upgrade to a newer sdkVersion you need to build a new binary with exp build. If I understand you correctly you built a standalone app with SDK 24, put that in the App Store, and then upgraded to SDK 27 and ran exp publish. That change will only go out to standalone apps built with SDK 27 or higher, see: https://docs.expo.io/versions/latest/distribution/building-standalone-apps#7-update-your-app

I did build a new binary and submitted it to the App Store…yes, exp build:IOS is what I did. It was after I got approval for the app with SDK 27, that I tried to publish an update. On my iphone, I updated the app as you usually do, but no OTA updates I do appear in the app.

Ok and have you opened the app multiple times? You have fallbackToCacheTimeout set to 0 so it will always use the cache and download the new version in the background.

I have opened the app several times, and yes, fallbackToCacheTimeout is set to 0. I did expect the download would happen in the background, but even after you open the app several times, you never see the update.

My guess is the new version either doesn’t get downloaded (most likely) or the code doesn’t open the most recent cache (which it appears to do).

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.