Open multiplayer app on the same machine gives error

Guys, I’ve created a game with the following setup App A – Backend – App B.
Now I want to play App A against App B.
If I only open App A and make a move, close the app and then open B to watch the move, it works.
However when I open both App A and App B at the same time, then I get the errors:

[sane] Warning: Lost connection to watchman, reconnecting…
/Users/jb/Library/LaunchAgents/com.github.facebook.watchman.plist: service already loaded
/Users/jb/Library/LaunchAgents/com.github.facebook.watchman.plist: service already loaded

What makes you think that a port in the backend code is hardcoded or something like that.
I have tried multiple solutions (like use ip instead of localhost) so far and none of them worked.
What is the solution for this problem?

Expo CLI 4.0.13 environment info:
OS: macOS Mojave 10.14.6
Shell: 3.2.57 - /bin/bash
Node: 14.15.1 - /usr/local/bin/node
npm: 6.14.8 - /usr/local/bin/npm
Platforms: iOS 13.2, DriverKit 19.0, macOS 10.15, tvOS 13.2, watchOS 6.1
Xcode: 11.3/11C29 - /usr/bin/xcodebuild
expo: ~39.0.2 => 39.0.5
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
expo-cli: 4.0.13
Expo Workflow: managed

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.