Open existing Expo project

Hi all,

I have the following problem:
I am trying to open an existing expo project that was using expo version 30.
Now my expo client uses version 31 so to be able to run it on my iOS device Id have to upgrade the code to v31.
After following the steps in doc on how to upgrade from v30 to v31 I ended up being able to load the log-in screen of the app but then I get the following error:

Invariant Violation: Invariant Violation: Objects are not valid as a React child (found: object with keys {opacity}). If you meant to render a collection of children, use an array instead.

in RCTText (at Text.js:145)

in TouchableText (at Text.js:268)

in RCTView (at View.js:44)

in ImageBackground (at VenueMarkerCircle.js:26)

in VenueMarkerCircle (at VenueMarker.js:79)

and many more components are affected…

Since this seems address the react-native Library, I really don’t have a clue what the error message is trying to tell me nor how to fix that problem.

Does anyone have a clue?

Note: Since I couldn’t go back to expo client v30 I can’t really say if I opened the existing project correctly.
I only cloned that repo with git and started the project with “expo start”. Could it be that there is more to it than just that?:see_no_evil:

Hi @mksquad,

After cloning, you’d have to run yarn or npm install to install all of the dependencies for whatever project it is you’re working on.

The error you got is basically saying you’re trying to render object, so this is an issue in your code. I’d follow the stack trace and debug from there.

I don’t think this is SDK related, but feel free to try and run it in this one of these older Expo clients, which are SDK 30 compatible:



thx for the reply, and thx for the link!

I managed to install the older clients on the simulator and the app is running (not everything is working as it should be at least its running)

That means it can only come from the upgrading part right?
Although I followed the steps described in:

Since I have some other react-native packages, i.e.
“react-native-navbar”: “^2.1.0”,
“react-native-scrollable-tab-view”: “^0.8.0”,
“react-native-view-more-text”: “^2.0.1”,
“react-navigation”: “^2.0.1”,

and I didn’t upgrade those…You think that could be the reason for the crash?
(See error above)

The thing is that I tried to trace down the error and I end up being deep in the react-native lib in some components and these are realms where I have the feeling that I shouldn’t be digging around…:see_no_evil:

It seems like this error affects a ton of components, custom ones as well as RN base components (like TouchableText,…)

Hope you have some bright ideas with the new info, Id really need to upgrade the Expo version.

And just a side question: Is it generally recommended to upgrade to every new Expo version asap ?
Or can I stay at a certain version when the app is completely finished and only minor things may change

Best regards,

I think you should go through the upgrade steps in the blog post again, as it specifies that you need to upgrade react-navigation to "^3.11.0", which you haven’t yet.

Is it generally recommended to upgrade to every new Expo version asap ?

Ideally, yes. Upgrading provides you with fixes and new features and all that good stuff, but you don’t need to. We look to keep ~6months backward support in terms of SDKs, and even after that your apps will continue to work, and you can still push js-only updates to those apps. (But yeah, I still recommend updating)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.