Only standalone Android app crashes suddenly with "Something wen wrong" blue screen

I published my app to PlayStore and AppStore in Feb. 21 and both worked very well. Many users successfully downloaded and used them.

However, about 12 hours ago, I found that the app downloaded from Playstore doesn’t run correctly. After showing splash screen, it shows blue screen with “Something went wrong”. If click “View error log”, “Uncaught Error: null is not an object (evaluating ‘t.length’)”

I did expo publish with specified release channel about three times to apply small updates. It seemed that this error began after I have published latest expo publish about 12 hours ago. So, I tried to rollaback with expo publish:rollback, so that there is no bundle in history.
But, still did not work.

If I run my app via Android expo client, it works well. there is no Uncaught error. Of course iOS app is OK with standalone and on Expo client.

So, I decided to release latest version to PlayStore.
Build: expo build:android --release-channel my-channel
Uploaded apk to PlayStore beta, and after about four hours later, I found that new version still causes error.

Can this be caused by expo building android bundle or apk?
Or can this caused by my app’s bug, which gets active only at standalone Android app?

Some of user began to complaining about this issue.

I tried to release a new version after removing node_modules and run npm i.
Succedded internal test released to PlayStore at Samsung Galaxy S8 (Android 8).
So, I released it to alpha test.
However, same error happens at Samsung Note 5(Android 7) and LG G6 (Android 8), but works well at Galaxy S8.

Very strange.

Sorry, that was my fault.
There was a bug, which only happens when the app is installed and run first.

You’re making our job easy solving these on your own, @herbertlim! :clap:

1 Like