Only see a white screen?

From Slack:

Hi there. I’m currently facing a wall. Starting a project with expo looks fine (“Project opened!..”), and pressing Device⇒Open on Android will start the application on my genymotion simulator. But the application only shows a white screen, expo log stays on “Opening on Android device” and no device logs appear.
Since I cannot get any log, I have not idea why the app won’t start. Clearing XDE cache, restarting the app won’t change anything.

Here are the steps I took:

  • Create a bare minimum expo project (no navigation stuff)
  • Check that it works (shown on android) and commit
  • add more commits with custom code
  • each code modification was breaking the app on the simulator, and I thought I was fixing it by restarting the expo project.
  • When I tried to change the default text, I realized that expo wasn’t showing the updated text but still the older version
  • Trying to checkout older commits, up to the bare minimum expo project, didn’t fix it.
    Couldn’t see any error at any point…

Using Expo XDE 2.18, expo 17, genymotion nexus 5…

Any idea what to do next ?

Did you find a solution for this?

While my app shared through Expo works allright on all my and a number of others devices, I have a test user who also only sees a white screen.

same here. Mine works, test user is saying white screen… any solution @minibbjd ?

hi- what apps are you sharing? can you post links to those? that will help get to the bottom of this.

Hi! I’m also stuck on this. Everything is looking great in Expo XDE but the Simulator is white. Reverted back to SDK version 19.0.0 because it seemed like there were simulator issues with the newest version. Any ideas on why Simulator isn’t rendering views? Thanks!

hi @mjolliffe, im not sure what the root cause is – there could be quite a few issues at play here. Would it be possible to present to us the simplest version of code that has this problem?

hi @quinlanj thanks for the speedy reply. I looked more into it and it seems like changes in React Navigation are what was causing the issue for me. Still trying to sort it out, but at least I am rendering some views.


I was running that on an Android Simulator was having the same problem. And here is what worked for me:

  • In the terminal, enter the command a this will direct expo to open the project on an Android Device ( although it was already running on it).
  • This loaded up my buttons without any designs but it was enough for me to locate them. I tapped on one of them that already had a defined functionality, and wallah, it loaded up the rest of the application neatly,