npm install expo-cli --global warnings and permissions/gyp errors (safe to ignore?)

I followed the instructions from to install thusly:

npm install expo-cli --global

That resulted in permissions errors so I retried as root:

sudo npm install expo-cli --global

And that seems to have worked except for warnings and gyp errors which I’ll get to next, but first, shouldn’t the instructions for installing be updated? I see here in the Forums I’m not the only one who got the permissions errors. I submitted a feature request. Is that the best way to contact the Expo team about that issue?

The warnings re: deprecated packages and skipping optional dependencies are okay to ignore? But why does the installer still reference deprecated packages? Should it be updated? Is that another feature request I should submit?

Here are the errors I got:

gyp WARN EACCES current user (“nobody”) does not have permission to access the dev dir “/root/.cache/node-gyp/12.16.1”
gyp WARN EACCES attempting to reinstall using temporary dev dir “/usr/lib/node_modules/expo-cli/node_modules/dtrace-provider/.node-gyp”
gyp WARN install got an error, rolling back install
gyp WARN install got an error, rolling back install
gyp ERR! configure error
gyp ERR! stack Error: EACCES: permission denied, mkdir ‘/usr/lib/node_modules/expo-cli/node_modules/dtrace-provider/.node-gyp’
gyp ERR! System Linux 5.3.0-7642-generic
gyp ERR! command “/usr/bin/node” “/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” “rebuild”
gyp ERR! cwd /usr/lib/node_modules/expo-cli/node_modules/dtrace-provider
gyp ERR! node -v v12.16.1
gyp ERR! node-gyp -v v5.0.5
gyp ERR! not ok

As advised by the Forums New Topic form I ran expo diagnostics which advised me to update to the newest version from 3.17.11 which I installed yesterday to 3.17.14 available today. The command given was slightly different:

npm install -g expo-cli

I prefixed again with sudo. This time I got no errors.

So I have no worries? Except for the fact that I got errors the first time? Doesn’t feel like I’m off to the best start here. BTW are the Forums monitored/answered by the Expo team or is it purely community?

I haven’t created an Expo project yet, but the expo command line at least is working so far.

$ expo diagnostics

Expo CLI 3.17.14 environment info:
OS: Linux 5.3 Pop!_OS 19.10
Shell: 5.0.3 - /bin/bash
Node: 12.16.1 - /usr/bin/node
Yarn: 1.22.4 - /usr/bin/yarn
npm: 6.13.4 - /usr/bin/npm
expo-cli: 3.17.14

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.