"npm install expo-cli --global" stuck at expo-cli@3.18.2 checking installable status

I am currently unable to install the expo-cli since it gets stuck at “checking installable status”.
No expo files are in my global node modules directory.

Here is what I have tried to fix the issue:

  • npm cache verify
  • Installing a previous version
  • npm install expo-cli --global --no-optional
  • npm cache clean --force

Any other module I want to install works, only expo-cli gets stuck. Anyone has an idea on how I can solve this issue?


1 Like

Same thing happens to me. Please I need solution ASAP

Facing the same issue,
node version v12.16.2
npm version ‘6.14.4’

I am having the same issue.
node version: 13.11.0
npm version: 6.13.7.

I tried the install again with verbose output and can see that it is working, it just takes a really long time.

As a temporary fix with npm, here is what I did :

npm install expo-cli@3.5.0 --global --verbose

when above install is finished:

npm install expo-cli@3.8.0 --global --verbose

when above install is finished:

npm install expo-cli@3.18.0 --global --verbose

I installed one after the other and it worked, but I couldn’t install the latest version.

Note: some files can take more than 900 000 ms to install & it took more than 1h-1h30 for the whole process.

If you would rather have the most recent version of expo-cli (and have a much quicker/simpler installation), you can use Yarn, but since I prefer npm I used my first solution:

yarn global add expo-cli

Let me know if this worked for you!

1 Like

I tried by installing the 3.5.0 but, it also took long time and i could not finish the proccess ! Still opened to proposal !

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.